Way of Elendil

  • Status Closed
  • Percent Complete
    100%
  • Task Type Rapport de bug
  • Category Sort
  • Assigned To
    Josh
  • Operating System
  • Severity Low
  • Priority Very Low
  • Reported Version 3.3.5
  • Due in Version Undecided
  • Due Date Undecided
  • Votes
  • Private
Attached to Project: 3.3.5
Opened by Martin - 09.04.2017
Last edited by Josh - 10.04.2017

FS#5390 - Cap valeur de blocage war prot

Ceci n'est pas un BT, mais une demande d'informations.

Je souhaiterais savoir de combien est le cap de valeur de blocage du bouclier par rapport aux degats du heurt de bouclier. (en gros jusqu'a quel cap la valeur de blocage augmente les degats du shieldslam)

J'ai lu pas mal de trucs, certains disent 2750, d'autres 1960, j'aimerai savoir ou vous en etes sur le serveur.

Closed by  Josh
10.04.2017 09:26
Reason for closing:  Pas un bug
Additional comments about closing:  Voir commentaire.
Admin
Eridium commented on 09.04.2017 15:20

http://wowwiki.wikia.com/wiki/Shield_Slam

Patch 3.3.2 (2010-01-02): The damage scaling from block value for this ability now diminishes faster and diminishes starting at a lower block value. The difference should be negligible for players in high-end tanking armor. In addition, the threat caused by Shield Slam has been increased by 30%.

Patch 3.2.0 (04-Aug-2009): The benefit from additional block value this ability gains is now subject to diminishing returns. Diminishing returns occur once block value exceeds 30 times the player's level and caps the maximum damage benefit from shield block value at 37.5 times the player's level.

default
Martin commented on 09.04.2017 15:36

Merci pour ces liens c'est bien ce que j'avais lu, donc en valeur brute on est a combien ?

Il y aussi le fait que certain trinket + proc force par exemple et la maitrise du blocage permettent de depasser ce cap, est ce bien le cas ici?

default
Martin commented on 09.04.2017 18:31

Une reponse please ?

 

Admin
Josh commented on 10.04.2017 09:26

uint32 block_value = m_caster->GetShieldBlockValue(uint32(float(level) * 24.5f), uint32(float(level) * 34.5f));

uint32 Unit::GetShieldBlockValue(uint32 soft_cap, uint32 hard_cap) const
{
    float value = (float)GetShieldBlockValue();
    float pctMod = GetShieldBlockValuePctMod();
    soft_cap *= pctMod;
    hard_cap *= pctMod;

    if (value >= soft_cap)
        value = (sqrt(8 *(value/soft_cap) + 1)-1)/2 * soft_cap;
    if (value >= hard_cap)
        value = hard_cap;
    return (uint32)value;
}

 

uint32 Player::GetShieldBlockValue() const
{
    float value = std::max(0.f, (m_auraBaseFlatMod[SHIELD_BLOCK_VALUE] + GetStat(STAT_STRENGTH) * 0.5f - 10) * GetShieldBlockValuePctMod());
    return uint32(value);
}

float Player::GetShieldBlockValuePctMod() const
{
    return m_auraBasePctMod[SHIELD_BLOCK_VALUE];
}

default
Martin commented on 10.04.2017 13:18

Ca ne me parle pas trop tout ca =(

Aurais tu la gentillesse de me donner le softcap et le hardcap en valeurs? (ex 3000 etc)

en essayant de dechiffrer un peu je trouver 2760 pour le hardcap ?

Admin
Josh commented on 10.04.2017 14:08

soft cap = niveau * 24.5

hard cap = niveau * 34.5

default
Martin commented on 10.04.2017 14:12

Je te remercie Josh =)

Loading...